COVID-19 Update
Incident Report for GlobalMeet
Resolved
“PGi monitoring continues to indicate carrier traffic has normalized across PSTN networks.
With the majority of the world resuming business, we will discontinue the COVID-19 daily update.”
Posted May 18, 2020 - 20:30 UTC
Monitoring
We have updated the list of impacted locations as of 05/14 and continue to monitor carrier networks.
Posted Mar 20, 2020 - 05:00 UTC
Update
Updated impacted locations.
Posted Mar 17, 2020 - 17:50 UTC
Investigating
Carriers are seeing large volumes of traffic flow through their PSTN networks as most of the world works remotely. PGi continues to monitor carrier networks.

If you are experiencing these issues, please use one of the alternatives below:
1. Connect via VoIP
2. Have the meeting call you
3. GlobalMeet for Outlook

We have a full featured support site available at https://www.mymeetinghelp.com/. This site has helpful documentation on our products as well as tips on how to work safe during the coronavirus/COVID-19 outbreak.

We continue working with carriers and scaling to ensure our customers have the support they need during this time. Thank you for your patience as we work through this.
Posted Mar 16, 2020 - 21:18 UTC
This incident affected: Collaboration Audio.