Experiencing Issues with Recording Replays and Reports from the GlobalMeet Admin Portal
Incident Report for GlobalMeet
Resolved
This incident has been resolved.
Posted May 12, 2020 - 12:00 UTC
Identified
Engineers are currently focusing on Recordings Replays and Reports on the GlobalMeet Admin Portal.
Posted Apr 29, 2020 - 20:18 UTC
This incident affected: GlobalMeet Admin Portal.