Live Streaming Performance Issue

Incident Report for GlobalMeet

Resolved

This incident has been resolved.
Posted May 21, 2026 - 09:45 UTC

Investigating

We are currently investigating an issue where GlobalMeet Webcast platform users may be experiencing service disruption during live streaming events.
Posted May 21, 2026 - 07:00 UTC
This incident affected: GlobalMeet Webcast.